Loading issues
Incident Report for Teamwork.com
Resolved
Some customers experienced issues accessing Teamwork services from the APAC region. This was due to an AWS Regional outage in APAC. Our team are continuing to investigate measures to mitigate impact of similar regional outages.
Posted Sep 10, 2024 - 08:50 UTC
Investigating
We are seeing some loading issues for some customers, we are investigating
Posted Sep 10, 2024 - 05:24 UTC
This incident affected: Teamwork Projects (Teamwork Projects - US region, Teamwork Projects - EU Region).